Экономикалық АҚпараттық ЖҮйелердегі жаңа технологиялар



жүктеу 0.66 Mb.
бет4/4
Дата22.02.2016
өлшемі0.66 Mb.
1   2   3   4

2-тапсырма. Қорытпалардың құрамын анықтау

Есепті қарап шығайық: А және В қорытпалар алу үшін І, ІІ, ІІІ және ІV металлдар қолданылады. Олардың А және В қорытпалардың құрамында болу талаптары 5.2 кестеде келтірілген.

І, ІІ, ІІІ және ІV металлдарын өндіруге қажетті кендер қорлары мен олардың мінездемелері 5.3 кестеде көрсетілген.
5.2-кесте – Қорытпа құрамын анықтау есебіндегі металлдардың қорытпа құрамында болу талаптары.

Қорытпа

Металл құрамына қойылатын талаптар


А

I металлының 80 %-нен артық емес

II металлының 30 %-нен артық емес

В

II металының 40 %-нен 60 %-не дейін

III металлының 30 %-нен кем емес

IV металлының 70 %-нен артық емес

5.3 Кесте– Қорытпа құрамын анықтау есебіндегі кендер мінездемесі мен қоры



Кен

Максималды қор, т

Құрамы, %

Баға, доллар

I

II

III

IV

басқа компоненттер

1

1000

20

10

30

30

10

30

2

2000

10

20

30

30

10

40

3

3000

5

5

70

20

0

50

А қорытпасының 1 т бағасы 200 долларов болсын, ал В қорытпасының 1 т – 210 доллар. А және В қорытпаларын сатқаннан келген пайданы максималдау қажет..

А және В қорытпаларын алуға қажетті І, ІІ, ІІІ және ІV металлдарының санын сәйкесінше , , , и , , , белгілейік. Қолданылған -нші кен санын деп белгілейік.

Осылай, бұл есептің математикалық моделі келесі түрге ие:

максималдау:



Қорытпа құрамына шек бойынша ( 2 кесте мәліметтері негізінде):
,

,

,

,

,

,
Кен құрамы мен мінездеме бойынша ( 3 кесте мәліметтері негізінде):
,

,

,

,
Сонымен қатар, айнымалыларды пайдалану диапазоны бойынша:

,

,

,

,
5.7 суретте көрсетілгендей, C3:D6 ұяшықтар диапазонын айнымалыларға бөлейік, ал F3:F5 ұяшықтар диапазонын айнымалырға бөлейік.


5.7-сурет – Қорытпа құрамын анықтау есебінің бастапқы мәліметтер.
G9 ұяшығына мақсатты функциян енгізейік

=200*СУММ(СЗ:С6)+210*СУММ(D3:D6)-30*F3-40*F4-50*F5

С8:С17 ұяшықтар диапазонына сол жақ шектерді енгізейік және оларды барлық айнымалылар сол жақта болатындай, ал тең емес белгілері – кем немесе тең болатындай түрге келтірейік:

=СЗ-0,8*СУММ(СЗ:С6),

=С4-0,3*СУММ(СЗ:С6),

=D4-0,6*СУММ(D3:D6),

=0,4*СУММ(D3:D6)-D4,

=0,3*СУММ(D3:D6)-D5,

=D6-0,7*СУММ(D3:D6),

=СУММ(СЗ:D3)-0,2*$F$3-0,1*$F$4-0,05*$F$5,

=СУММ(С4:D4)-0,1*$F$3-0,2*$F$4-0,05*$F$5,

=СУММ(С5:D5)-0,3*$F$3-0,3*$F$4-0,7*$F$5,

=СУММ(С6:D6)-0,3*$F$3-0,3*$F$4-0,2*$F$5.

НЗ:Н5 ұяшықтар диапазонына қорды бар кен санын енгізейік. 5.8 суретте көрсетілгендей Сервис, Шешім іздеу командаларын таңдап, Шешім іздеу терезесін толтырайық.

Қажетті ұяшықтарды және шектерді толтырғаннан кейін Орындау батырмасын басыңыз.

5.8-сурет – қорытпа құрамын анықтау есебіндегі Шешім іздеу терезесі

3-тапсырма. Кəсіпорын төрт түрлі өнім шығарады: Ө1, Ө2, Ө3, Ө4. Оны өндіруде үш ресурс қолданылады: еңбек, шикізат жəне құрал-жабдық. Əр ресур бойынша шығын төмендегі 5.4 кестеде берілген:
5.4-кесте – Өнімді шығаруға жұмсалатын ресурстар нормасы

Ресурс

Өнім түрі

Ресурс көлемі

Ө1

Ө2

Ө3

Ө4

Еңбек

1

1

1

1

16

Шикізат

6

5

4

3

110

Құрал-жабдықтар

4

6

10

13

100

Өнімді сатқаннан түсетін пайда: Ө1 – 60, Ө2 – 70, Ө3 – 120, Ө4 – 130.

Кəсіпорынның пайдасын максималдау үшін əр өнім бойынша өндірудің тиімді жоспарын құрыңыз.

6 Транспорттық есеп
6.1 Транспорттық есептің математикалық моделі

Жалпы түрде транспорттық есепті былай түсіндіруге болады: m пунктте: A1, …, Am біртекті жүк бар. Жүктің көлемі сəйкесінше a1, …, am. Бұл жүкті тұтынушыларға (B1, …, Bn) жеткізу керек. Олардың сұранысы – b1, …, bn. Тасымалдау құны i-ші (i=1,m) пункттен j-ші (j=1,n) пунктке дейін cij. Тұтынушылардың сұраныстарын толық қанағаттандыратын жəне транспорттық шығындар минималды болатын жоспар құрыңыз.

Есепті математикалық жазу түрінде былай беруге болады:
(1)

(2)



(3)
Сонымен, берілгені: сызықтық функция (1), шарттар (3), шектеулер жүйесі (2). Шешімдер жиынынан (2) сызықтық функцияның (1) минимумы болатын теріс емес шешімін тау керек.

Егер жүк жеткізушідегі жүктің жиынтық көлемі тұтынушыға керек жүктің жиынтық көлеміне тең болса, онда транспорттық есеп жабық (балансталған) деп аталады: яғни, төмендегі теңдік орындалса:



Егер төмендегі шарттардың бірі орындалса, онда транспорттық есеп ашық (балансталмаған) деп аталады:

Транспорттық есептің шешімі болу үшін ашық модельді жабық модельге айналдыру керек.

- Егер шарты орындалса, онда фиктивті (n+1)-ші пунктті

Bn+1 кіргіземіз, яғни есепке қосымша баған кіргізіледі. Бұл тұтынушының сұранысы мынаған тең болады:



Тасымалданатын жүктің құны нөлге тең болады, яғни, .

Егер шарты орындалса, онда фиктивті (m+1)-ші жеткізушіні Am+1 кіргіземіз, яғни, есепке қосымша жол кіргізіледі. Бұл жеткізушідегі жүк мынаған тең деп алынады:



Тасымалданатын жүктің құны нөлге тең болады, яғни, .

Ашық модельді жабық модельге айналдырғанда мақсаттық функция өзгермейді, өйткені қосымша жүк тасымалына сəйкес келетін қосылғыштар нөлге тең.



6.2 Тақырып бойынша тапсырмалар

1-тапсырма. Транспорттық есеп

Шешім іздеу құралы қолданылатын тағы бір мысалды қарастырайық. Төрт фабрика және оның өнімдерін өткізу бес орталықтарға ие фирма бар деп шамалайық. Күніне 200, 150, 225 және 175 өндіріс мүмкіншіліктерге ие фирма фабрикалары Денвер, Бостон, Новый Орлеан және Даллас қалаларында орналасқан. Күніне 100, 200, 50, 250 және 150 қажеттіліктерге ие фирма өнімдерін өткізу орталықтары сәйкесінше Лос-Анджелес, Даллас, Сент-Луис, Вашингтон және Атланта сында орналасқан. Өткізу орталығына жіберілмеген фабрикада өнім бірліктерді сақтау күніне 0,75 доллар қымбатқа түседі, ал тұтынушының өткізу орталығында тапсырыс берілген, бірақ мерзімі өткен өнім бірлігі үшін күніне 2,5 доллар қымбатқа түседі. Фабрикадан өткізу орталықтарға шейін өнім бірлігін тасымалдау құны 6.1 кестеде көрсетілген.


6.1-кесте– Транспорттық шығындар




1

2

3

4

5

Қалалар

Лос-Анджелес

Даллас

Сент-Луис

Вашингтон

Атланта

Денвер

1,5

2

1,75

2,25

2,25

Бостон

2,5

2

1,75

1

1,5

Новый Орлеан

2

1,5

1,5

1,75

1,75

Даллас

2

0,5

1,75

1,75

1,75

Көліктік шығындарды минималдандыру үшін тасымалдауларды дұрыс жоспарлау қажет.

Бұл модель балансталғандықтан (өдірілген өнім көлемінің сомасы оның ішіндегі қажеттіліктер көлемінің сомасына тең бөлінген), өнім жеткізбеушілік және қоймалауға байланысты шығындарды санамауға болады. Басқа жағдайда келесі мәліметтерді енгізу керек:



  • артық өндіру жағдайында – жалған өткізу орталығын, қоймалау құны кіретін өнім бірлігінің бірдей тасымалдау құнын, ал тасымалдау көлеміне – өнім артықтарының қоймалау көлемдерін;

  • тапшылық жағдайында – жалған фабриканы , өнімді жеткізбеу айып пұлдары кіретін өнім бірлігінің бірдей тасымалдау құнын, ал тасымалдау көлеміне – өткізу орталықтарына жеткізілмеген өнім көлемін.

Бұл есепті шығару үшін оның математикалық моделін құрастырайық. Осындағы белгісіздер тасымалдау көлемі болып табылады. – i-нші фабрикадан j-нші өткізу орталыққа тасымалдау көлемі. Мақсатты функция – көліктік шығындардың сомасы, яғни:
,
мұндағы – i-нші фабрикадан j-нші өткізу орталыққа өнім бірлігінің тасымалдау құны.

Белгісіздер келесі шектеулерді қанағаттандыру керек:



  • тасымалдау көлемі теріс бола алмайды.

  • модель балансталғандықтан, бүкіл өнім фабрикадан шығарылу керек, ал бүкіл өткізу орталықтардың қажеттіліктері толығымен қанағаттандырылу керек.

Нәтижесінде келесі модель пайда болады: минималдандыру келесі шектеулерде:

,
,
.
мұндағы – i-нші фабриканың өндіріс көлемі; – j-нші өткізу орталығының сұранысы.

6.1 суретте көрсетілгендей бұл есепті шешу үшін шешім іздеу құралы көмегімен бастапқы мәліметтерді енгізейік.

А1:Е4 ұяшықтарына тасымалдау құнын енгіземіз. А6:Е9 ұяшықтары белгісіздер (тасымалдау көлемі) үшін бөлінген. G6:G9 ұяшықтарына фабрикадағы өндіріс көлемі енгізілген, ал А11:Е11 ұяшықтарына өткізу орталықтарының қажеттіліктері енгізілген.

F10 ұяшығына мақсатты функция енгізілген.

=СУММПРОИЗВ(А1:Е4;А6;Е9)

6.1-сурет– Транспорттық есептің бастапқы мәліметтері
А10:Е10 ұяшықтарына өткізу орталықтарына әкелінетін өнім көлемін анықтайтын келесі формулалар енгізілген

=СУММ(А6:А9),

=СУММ(В6:В9),

=СУММ(С6:С9),

=СУММ(D6:D9),

=СУММ(Е6:Е9),

F6:F9 ұяшықтарына фабрикадан шығарылатын өнім көлемін анықтайтын формулалар енгізілген.

=СУММ(А6:Е6),

=СУММ(А7:Е7),

=СУММ(А8:Е8),

=СУММ(А9:Е9),

6.2 суретте көрсетілгендей Сервис, Шешім іздеу командасын таңдап, ашылған Шешім іздеу терезесін толтырамыз.



6.2-сурет– Транспорттық есеп үшін Шешім іздеу сұхбат терезесі

Іздеу параметрлері терезесінде Сызықтық модель тұсында жалау қоюды ұмытпаңыз. 6.3 суретте көрсетілгендей Орындау батырмасын басқаннан кейін шешім іздеу құралы өнім жеткізудің ең тиімді жолын және оған тиісті көліктік шығындарды анықтайды.

6.3-сурет – Транспорттық есептің тиімді шешімі
2-тапсырма. Тағайындаулар туралы есептер

Тағайындаулар туралы есептерді шешудің мысалын қарастырайық. Төрт жұмысшы жұмыстың төрт түрін орындай алады. j-й жұмысының i-м жұмысшымен орындауының бағасы 6.4 суретте A1:D4 диапазонының ұяшықтарында келтірілген.



6.4-сурет - Тағайындаулар туралы есебіндегі жұмыстардың бағалары

Бұл кестеде жолдар жұмысшыларға сәйкес келеді, ал баған – жұмыстарға. Барлық жұмыстар орындалғандай етіп, әрбір жұмысшы тек бір жұмыста ғана болатындай етіп, ал барлық жұмыстардың орындалуының жиынтық бағасы минималды болатындай етіп жұмыс орындау жоспарын құру керек. Берілген есеп теңгерілген, яғни жұмыс саны жұмысшылар санына тең екенін атап көрсету керек. Егерде есеп теңгерілмеген болса, онда оны шешудің алдында есепті теңгеру керек, ол үшін жұмыстың жоғары құндары бар жетпейтін жолдардың немесе бағандардың санын енгізу керек.

Берілген есепті шешу үшін оның математикалық моделін құрайық. Егер i жұмысшымен j жұмысы орындалса, онда , егерде i жұмысшымен j жұмысы орындалмаса, онда . Онда модель келесі түрге ие: минимизациялау келесі шектеулерде:

,
,
.
Шешімді іздеу құралдарының көмегімен бұл есепті шығару үшін белгісіздерге F2:I5 ұяшықтарының диапазонын бөлейік. J1ұяшығына жұмыстардың бағасын есептейтін мақсаттық функцияны енгіземіз:

=СУММПРОИЗВ(F2:I5;A1:D4),

6.5 суретте көрсетілгендей шектеулердің сол жақтарына сәйкес келетін формулаларды енгіземіз.

6.5-сурет - Тағайындаулар туралы есептегі шектеулердің сол жақтары
Бұдан кейін Сервис, Поиск решения командасын таңдаймыз және ашылған Поиск решения сұхбат терезесін 6.6 суретте көрсетілгендей толтырамыз.

6.6-сурет – Тағайындаулар туралы есебінің Поиск решения сұхбат терезсі
Параметры поиска решения сұхбат терезесінде Линейная модель флажогын орнатуды ұмытпаңыз. Выполнить батырмасын басқаннан кейін шешімді іздеу құралы 6.7 суретте келтірілген тиімді ешімді табады.

6.7-сурет– Тағайындаулар туралы есебіндегі жұмыстардың тиімді жоспары

Әдебиеттер
1 Байшоланова Қ. С. Ақпараттық жүйелер теориясы. –    Алматы, 2007. – 280 б.

2 Балапанов, Е. Қ., Бөрiбаев, Б., Дәулетқұлов, А. Б.   Жаңа информациялық технологиялар: информатикадан 30 сабақ : оқулық. 4 басылым, жөнделiп толықтырылған. – Алматы : ЖТИ, 2007. – 408 б.

3 Бралиев Н. Б. и т.б. Ақпаратты жүйелер бизнесте. – Алматы : РИК, 2007. – 325 6.

4 Исаев С. Ә., Мұхамади А. Н., Ахметова О. С. Компьютерлік технология негіздері курсына арналған практикум. – Алматы, 2007.–305 б.

5 Хакимова Т. Компьютерлік өңдеудің әдістемелері. Алматы : «Ғылым», 2007.-453 б.

6 Халықова К. З. Информатиканы оқыту әдістемесі. Алматы : «Білім», 2007.- 250 б.

7 Гарнаев А. Использование MS Excel и VBA в экономике и финансах. К-М-СПб., 2000. - 510 б.

8 Ермеков Н., Ермеков М., Ноғайбаланова С. Информатика. Алматы : «Жазушы», 2005.-354 б. 

9 Информационные технологии в маркетинге. /Под ред. Г.А. Титоренко.- М : ЮНИТИ-ДАНА, 2000.- 407 б.

Мазмұны
Кіріспе 3

1 MS Excel функциялары мен формулалары 4

1.1 Формулалармен жұмыс 4

1.2 Функциялар 7

1.3 Логикалық функциялар 9

1.4 Диаграммалар (Графиктер) 10

1.5 Құрама кестелер 10

1.6 Тақырып бойынша тапсырмалар 12

2 MS Excel-де экономикалық есептеулер жүргізу 20

2.1 Финанстық функциялармен жұмыс 20

2.2 Тақырып бойынша тапсырмалар 26

3 Параметрді келтіру 28

3.1 Параметрді келтіру құралын пайдалану мысалдары 28

3.2 Тақырып бойынша тапсырмалар 30

4 Қою кестесі 32

41. Бір айнымалысы бар қою кестесін қолдану 32

4.2 Екі айнымалысы бар қою кестесін қолдану 33

4.3 Тақырып бойынша тапсырмалар 35

5 Шешімді іздеу (Поиск решения) баптамасының көмегімен

тиімділеу есептерін шығару 37

5.1 Шешімді іздеу баптамасы 37

5.2 Тақырып бойынша тапсырмалар 40

6 Транспорттық есеп 47

6.1 Транспорттық есептің математикалық моделі 47

6.2 Тақырып бойынша тапсырмалар 48

Әдебиеттер 54




1   2   3   4


©dereksiz.org 2016
әкімшілігінің қараңыз

    Басты бет