Произаодственная практика профессионального модуля



бет14/15
Дата18.05.2022
өлшемі0.93 Mb.
#457176
1   ...   7   8   9   10   11   12   13   14   15
Отчёт
Metodichka proizv praktika PM 01
КонецЕсли;
КонецЦикла;
// регистр Остатки Расход
Движения.Остатки.Записывать = Истина;
Для Каждого ТекСтрокаМатериалы Из Материалы Цикл
Движение = Движения.Остатки.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.Товар = ТекСтрокаМатериалы.Наименование;
Движение.Склад = Склад;
Движение.Количество = ТекСтрокаМатериалы.Количество;
Движение.Комментарий = Комментарий;
КонецЦикла;
//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры


Модуль формы документа «Расходная накладная»
&НаКлиенте
Процедура МатериалыКоличествоПриИзменении(Элемент)
СтрокаТЧ = Элементы.Материалы.ТекущиеДанные;
НаКлиенте.ЗаполнитьСтрокуТабЧасти(СтрокаТЧ);
КонецПроцедуры
&НаКлиенте
Процедура МатериалыНаименованиеПриИзменении(Элемент)
СтрокаТЧ = Элементы.Материалы.ТекущиеДанные;
СтрокаТЧ.Цена = НаСервере.ВыбратьЦенуНоменклатуры(СтрокаТЧ.Наименование, Объект.ТипЦены, Объект.Дата);
НаКлиенте.ЗаполнитьСтрокуТабЧасти(СтрокаТЧ);
КонецПроцедуры


Модуль формы документа «Инвентаризация»
&НаСервере
Функция ЗапросОстатков(ВыбСклад)
Запрос = Новый Запрос;
Запрос.УстановитьПараметр("Склад",ВыбСклад);
Запрос.Текст = "ВЫБРАТЬ
| ОстаткиОстаткиИОбороты.Товар,
| ОстаткиОстаткиИОбороты.КоличествоКонечныйОстаток,
| ОстаткиОстаткиИОбороты.Склад
|ИЗ
| РегистрНакопления.Остатки.ОстаткиИОбороты(, , , , Склад = &Склад) КАК ОстаткиОстаткиИОбороты
|ГДЕ
| ОстаткиОстаткиИОбороты.Склад = &Склад";
Результат = Запрос.Выполнить().Выгрузить();
МассивЗапроса = новый Массив;
Для каждого Эл из Результат Цикл
СтруктураЗапроса = новый структура;
СтруктураЗапроса.Вставить("Товар",Эл.Товар);
СтруктураЗапроса.Вставить("КоличествоКонечныйОстаток",Эл.КоличествоКонечныйОстаток);
МассивЗапроса.Добавить(СтруктураЗапроса);
КонецЦикла;
Возврат МассивЗапроса;
КонецФункции
&НаКлиенте
Процедура СкладПриИзменении(Элемент)
ТЧ = Объект.Товары;
Результат = ЗапросОстатков(Объект.Склад);
ТЧ.Очистить();
Для Каждого ЭлементРезультата из Результат Цикл
НоваяСтрокаТЧ = ТЧ.Добавить();
НоваяСтрокаТЧ.Наименование = ЭлементРезультата.Товар;
НоваяСтрокаТЧ.КоличествоПоУчету = ЭлементРезультата.КоличествоКонечныйОстаток;
НоваяСтрокаТЧ.КоличествоФакт = ЭлементРезультата.КоличествоКонечныйОстаток;
НоваяСтрокаТЧ.Отклонение = НоваяСтрокаТЧ.КоличествоФакт - НоваяСтрокаТЧ.КоличествоПоУчету;
КонецЦикла;
КонецПроцедуры


&НаКлиенте
Процедура ТоварыКоличествоФактПриИзменении(Элемент)
СтрокаТЧ = Элементы.Товары.ТекущиеДанные;
СтрокаТЧ.Отклонение = СтрокаТЧ.КоличествоФакт - СтрокаТЧ.КоличествоПоУчету;
КонецПроцедуры


Модуль документа «Перемещение товара по складам»
Процедура ОбработкаПроведения(Отказ, Режим)
//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!



Для Каждого ТекСтрокаПеремещение Из Перемещение Цикл
Если ТекСтрокаПеремещение.Наименование.ВидНоменклатуры = Перечисления.ВидНоменклатуры.Услуга Тогда


Достарыңызбен бөлісу:
1   ...   7   8   9   10   11   12   13   14   15




©dereksiz.org 2022
әкімшілігінің қараңыз

    Басты бет