Анықтамалық есеп берулер кезіндегі мәліметтерді енгізу үшін немесе құжаттарды толтыру үшін қолданылатын бір типті объектілер. Көбінесе анықтамалықтар болып қызметкерлер, мекемелер, материалдар тізімі болып табылады



бет4/5
Дата26.06.2016
өлшемі1.28 Mb.
түріАнықтамалық
1   2   3   4   5

Бақылау сұрақтары:

1) 1С неше режимде жұмыс жасай алады?

2) Атаудың ұзындығы неше символдан тұрады?

3) Құжаттардың өткізілуі дегеніміз не?

4) Құжаттың анықтамалықтан айырмашылығы неде?
Практикалық жұмыс №2. Ақпараттық –анықтамалық жүйесі
Мақсаты: Жұмысқа тұру үшін арналған оңай ақпараттық-анықтамалық жүйені құру керек.

Жүйеде жұмыс берушілер мен жұмыс іздеушілердің тізімі сақталуы керек. Әр жұмыс берушіде бірнеше вакансия болуы мүмкін. Әр жұмыс іздеушіде бірнеше резюме болуы мүмкін. Жүйе жұмыс берушілерге жұмыскерлерді таңдауға, ал жұмыс іздеушілерге жұмыс орнын табуға мүмкіндік береді.


Конфигурация объектілері

Конфигурацияда келесі объектілерді құру керек:





Объекттер типі

Объекттер

Анықтамалықтар

  • Работодатели

  • Соискатели

  • Вакансии

  • Резюме

  • Должности

Тізбектеу

  • ВидОбразования

  • ГрафикРаботы

  • Пол

Өңдеу

  • ЧисткаБазы

Тізбектеу:

ОқуТүрі

Среднее

СреднеСпециальное

НезаконченноеВысшее

Высшее


ОқуГрафигі


ПолныйРабочийДень

НеполныйРабочийДень

СвободныйГрафик


Жынысы

Мужской

Женский




«Работодатели» анықтамалығы
Берілген анықтамалықта өз вакансияларын ұсынатын фирмалар және жеке кәсіпкерлер жайында ақпараттар сақталады. «Вакансии» батырмасына басқанда берілген жұмыс берушінің ұсынып отырған вакансия тізімі ашылады.


Сурет 24 – «Работодатель» анықтамалығының формасы




Сурет 25 - «Работодатель» анықтамалығының конструкторының формасы



«Соискатели» анықтамалығы
Берілген анықтамалықта өз резюмелерін ұсынған жұмыс іздеушілер туралы ақпараттар сақталады. «Резюме» батырмасын басқанда берілген жұмыс іздеушінің резюме тізімі шығуы керек. Әр жұмыс іздеушінің бірнеше резюмесі болуы мүмкін. Мысалы, жұмыс іздеуші 1С және Photoshop біледі, бірақ оларды бір резюмеде көрсетуге болмайды. Өз-өзіңді өте нақты жағынан көрсету керек, жұмыс берушілер барлығын білетін адамдарды жақтырмайды.

Сурет 26 - «Соискатели» анықтамалығының формасы



Сурет 27 - «Соискатели» анықтамалығының конструкторының формасы



«Резюме» анықтамалығы
Берілген анықтамалықта жұмыс іздеушілердің резюмелері сақталады. Әр жұмыс іздеушіде бірнеше резюме болуы мүмкін. «Поиск подходящих вакансий» батырмасын басқанда бағдарлама вакансиялар тізімін қарап шығып, берілген резюмеге сай келетін резюмелерді таңдайды.

Сурет 28 - «Резюме» анықтамалығының формасы




Сурет 29 - «Резюме» анықтамалығының конструкторының формасы



«Вакансии» анықтамалығы
Берілген анықтамалықта жұмыс берушілердің вакансиялары тураы ақпараттар сақталады. Әр жұмыс берушіде бірнеше әртүрлі вакансиялар болуы мүмкін. Кейбір жолдарды толтырмауға болады, мысалы, «ГрафикРаботы», «Образование», «Пол». Бұл жұмыс берушіні мұндай берілгендер қызықтырмайды дегенді білдіреді. «Поиск подходящих резюме» батырмасын басқанда бағдарлама резюме тізімін қарап шығып, берілген вакансияға сай келетін резюмелерді таңдап алады.

Сурет 30 - «Вакансия» анықтамалығының формасы




Сурет 31 - «Вакансия» анықтамалығының конструкторының формасы



«Чистка базы» өңдеуі
Берілген өңдеу орналастыру мерзімі өтіп кеткен вакансиялар мен резюмелерді іздеп тауып, оларды жоюға белгілейді.

Сурет 32 - «Чистка базы» өңдеуінің формасы




Бақылау сұрақтары:

1) Бұл жұмыста қандай анықтамалықтар қолданылады?

2) «Вакансия» анықтамалығының қызметі?

3) «Резюме» анықтамалығында қандай реквизиттер бар?

4) Объект дегеніміз не?

Практикалық жұмыс №3. Қоймалармен жұмыс жасау жүйесі
Мақсаты: Материалдарды қабылдайтын және жіберетін, сонымен қатар қалған материалдар бойынша есеп беретін оңай бірнеше складтарға арналған складтық тіркеу жүйесін құру.

Конфигурация объектілері

Конфигурацияда келесі объектілерді құру керек:



Объекттер типі

Объекттер

Анықтамалықтар

  • Материалы (количество уровней: 3)

  • Склады

Құжаттар

  • Приход
    (реквизиты шапки: Склад,
    реквизиты табличной части: Материал, Количество)

  • Расход
    (реквизиты шапки: Склад,
    реквизиты табличной части: Материал, Количество)

При создании документов не забудьте поставить галочку "Оперативный учет", чтобы данный документ мог делать движения в регистрах.

Құжаттар журналы

  • Складские

Регистрлер

  • ОстаткиМатериалов

Есеп берулер

  • ОстаткиМатериалов


«Приход» құжаты

«Приход» құжатының экрандық формасы келесідей болады:



Сурет 33 - «Приход» құжатының экрандық формасы


«Расход» құжаты

«Расход» құжатының экрандық формасы келесідей болады (тек атауымен ерекшеленеді):



Сурет 34 -«Расход» құжатының экрандық формасы

«Остатки материалов» есебі

Диалогтың экрандық формасы келесідегідей болады:



Сурет 35 - «Остатки материалов» есебінің диалогтық экрандық формасы
Есеп модулі:



Бақылау сұрақтары:

1) Бұл жұмыста қандай құжаттар қолданылады?

2) Конфигурацияда қолданылтаны объектілерді ата?

3) Өңдеу дегеніміз не?


Практикалық жұмыс №4. Пошталық жүйесі

Мақсаты: Кәсіпорынның локальді желісі үшін почталық жүйе құру керек.
Жүйе хат жіберуге мүмкіндік беруі қажет және жалпы чат болуы қажет. Әр қолданушының одан хат алғысы келмейтін оның адамдары болуы мүмкін. Хатқа 1С:Кәсіпорын базасының объектілерін, мысалы, товарлар, накладнойлар және т.б. қосу мүмкіншілігі болу керек.

Конфигурация объектілері

Конфигурацияда келесі объектілерді құру керек:



Объекттер типі

Объекттер

Анықтамалықтар

  • Пользователи

  • Черный список (подчинен спр. Пользователи)

Құжаттар

  • Письмо

  • Сообщение

Журналдар

  • Письма

  • Чат

Өңдеулер

  • ЧисткаБазы

Глобальдік модульдің бағдарламасы:







«Пользователи» анықтамалығы
Берілген анықтамалықта конфигурация қолданушылары туралы ақпараттар болады. Факті бойынша – бұл почталық қорап тізімі болады. Жүйеге кіру кезінде осы анықтамалықта логинді іздеу жүргізіледі, егер ол табылмаса, онда анықтамалыққа автоматты түрде жаңа қолданушы енгізіледі. Глобальді айнымалы ТекПользователь жүйенің жұмыс басында осы анытамалықтан мән алады, яғни осы айнымалы бойынша бағдарламаның кез-келген модулінде конфигурациямен қандай қолданушы жұмыс жасап жатқанын білуге болады.

Сурет 36 – «Пользователи» анықтамалығының формасы
Берілген анықтамалықта келесідей жолдар болады:

  • Код

  • Наименование (краткое имя, логин)

  • ПолноеИмя

  • Подпись (для подстановки в новые письма)

  • ЕстьПисьмо (флажок, который показывает, что пришла новая почта)




Сурет 37 – «Пользователи» анықтамалығының кестелік формасы
«Черный список» анықтамалығы

Берілген анықтамалықта әр қолданушының олардан хат алғысы келмейтін адамдар тізімі сақталатын болады. Анықтамалықты ашқанда дәл сол кездегі қолданушының олардан хат алғысы келмейтін, бағдарламамен жұмыс істеп отырған адамдар тізімі болады.



Сурет 38 – «Черный список» анықтамалығының конструкторлық формасы
Анықтамалықта жалғыз «Недруг» жолы бар, оның мәндері «Пользователи» анықтамалығынан таңдалады.

Сурет 39 – «Черный список» анықтамалығының кестелік формасы

«Письмо» құжаты

Берілген құжаттың шапкасы мен кестелік бөлігі болады. Шапкада кім хат жазды, ол кімге арналған, хаттың темасы, хаттың мәтіні және қажеттілік жалаушасы орналастырылады. Кестелік бөлікте хатқа қосымша болады. Қосымша ретінде кішкене мәтіні бар кез-келген анықтамалық немесе құжат бола алады.



Сурет 40 – «Письмо» анықтамалығының конструкторлық формасы
Берілген почтаның Outlook-тен айырмашылығы, ол хатқа 1С базасының нақты бір объектісін қоса алады. Яғни, қолданушы мынандай хат жібере алады: «Света, посмотри, что творится с этой накладной!» және оған накладнойдың өзін қосуына болады.


Сурет 41 – «Письмо» анықтамалығының экрандық формасы
Ал «Приложения» салымына тауарлардың өзі комментариилермен қосылған.

Сурет 42 – «Письмо» анықтамалығының беттерінің экрандық формасы
Хатты сақтағанда келесі жағдай жүргізіледі. Адресатта еденицаға «ЕстьПисьмо» жалауша «Пользователи» анықтамалығына қойылады. Әр бірнеше секунд сайын жаңа почтаны тексеру жүргізіледі, егер жалауша қойылса және әлі хабар келмеген жаңа оқылмаған хаттар болса, онда қолданушыға хат келеді: «Пришла почта! Прочитать?». «ЕстьПисьмо» жалаушасы алынып тасталады және қолданушыға ескерту келген хаттарда «БылоОповещено» жалаушасы қойылады. Егер қолданушы «Иә» деп жауап берсе, онда оның почталық қорабы ашылады («Письма» журналы).
«Письма» журналы

Сурет 43 – «Письма» журналының конструкторлық формасы


Бұл журнал пошталық қорап ретінде саналады. Журналды ашқан кезде тек сол уақыттағы қолданушының хаттары ғана шығады. Бұл қолданушылар басқа біреудің хаттарын оқымас үшін қажет.

Сурет 44 – «Письма» журналының пошталық формасы



«Сообщение» құжаты

Сурет 45 – «Сообщение» құжатының конструкторлық формасы
Берілген құжат жалпы чатқа арналған қысқа хабарлама болып табылады. Құжатты сақтағанда ол «Чат» журналында көрсетіледі.

Сурет 46 – «Сообщение» құжатының формасы

«Чат» журналы

Сурет 47 – «Чат» журналының конструкторлық формасы
Берілген журнал «Сообщение» құжаттарын көрсетеді және чат секілді болып келеді. Кез-келген қолданушы жаңа «Сообщение» құжатын құрастырып және оны сақтай алады, сонда бірнеше секундтан кейін оны осы журналдағы басқа да қолданушылар көреді. Байланыс орналастырылды.

Сурет 48 – «Чат» журналының формасы

«Что мне сказали» батырмасына басқанда, дәл сол кездегі қолданушыға ғана арналған хабарламалар ғана шығады. «Все сообщения» батырмасы қайтадан барлық қолданушыларға барлық хабарламаларды көрсетеді.


«Чистка базы» тазартқышы
Берілген тазартқыш ескі оқылған хаттарды, хабарламаларды тауып, оларды жойып жіберуге белгілейді.

Сурет 49 –«Чистка базы» формасы


Бақылау сұрақтары:

1) Бұл жұмыста қандай құжаттар қолданылады?

2) Бұл жұмыстың нәтижесі неге әкеледі?

3) Форма дегеніміз не?

4) Секция дегеніміз не?
Практикалық жұмыс №5. Отбасылық шығыстар мен кірістерді реттеу жүйесі
Мақсаты: Отбасылық шығыстар мен кірістер жүйесінің тіркеуін құру.

Жүйе отбасының әр мүшесінің сол уақыттағы қалған ақшасын және жалпы отбасылық салымдарды көрсетуі тиіс. Жүйе берілген периодта қатысушылар бойынша группировкамен немесе шығыстар мен кірістер статьясы бойынша отбасының шығыстары мен кірістерін білуге мүмкіндік беруі тиіс.


Конфигурация объектілері

Конфигурацияда келесі объектілерді құру қажет:




Объктілер типі

Объекттер

Анықтамалықтар

  • Қатысушылар

  • Қалталар (қосымша. реквизит Қатысушы)

  • Кіріс

  • Шығыс

Құжаттар

  • Кіріс
    (шапка реквизиттері: Қатысушы, Статья, Қалта, Сомма)

  • Шығыс
    (шапка реквизиттері: Қатысушы, Статья, Қалта, Сомма)

  • Перевод
    (шапка реквизиттері: ҚалтаҚайдан, ҚалтаҚайда, Сомма)

  • БастҚалдықЕнгізу
    (кесте бөлімінің реквизиттері: Қалта, Сомма)




Құжаттар журналы

  • БарҚұжаттар

Регистрлер

  • Қалта (регистр қалдығы)

  • Кіріс (айналым регистр)

  • Шығыс (айналым регистр)

Есеп берулер

  • Қалдық

  • КірісШығыс


«Қатысушылар» анықтамалығы

Берілген анықтамалықта кіріс пен шығыстар жүргізілетін және кошелектарға ие болатын отбасы мүшелерінің аттары жазылады.




Сурет 50 –«Қатысушылар» анықтамалығының формасы

«Қалта» анықтамалығы
Берілген анықтамалықта отбасының ақшалай қаражатының сақталатын жерлерінің атаулары жазылады.


Сурет 51 –«Қалта» анықтамалығының формасы

«Кіріс» анықтамалығы
Берілген анқытамалықта отбасылық ақша қаражаттың кіретін жерлерінің атаулары жазылады.

Сурет 52 –«Қалта» анықтамалығының формасы

«Кіріс» анықтамалығы
Берілген анықтамалықта отбасылық қаражаттардың жұмсалатын бағыттарының атаулары жазылады. Бұл көпдеңгейлік анықтамалық.

Сурет 53 –«Кіріс» анықтамалығының формасы
«Бастапқы қалдықтарды енгізу» құжаты
Құжаттың экрандық формасы келесідегідей көрінеді:

Сурет 53 –«Бастапқы қалдықтарды енгізу» құжатының формасы
Өткізу модулі:
Процедура ОбработкаПроведения()

ВыбратьСтроки();


Пока ПолучитьСтроку()=1 Цикл

Регистр.Кошельки.Кошелек = Кошелек;


Регистр.Кошельки.Сумма = Сумма;
Регистр.Кошельки.ДвижениеПриходВыполнить();

КонецЦикла;

КонецПроцедуры

«Кіріс» құжаты

Құжаттың экрандық формасы келесідегідей болып көрінеді:



Сурет 54 –«Кіріс» құжатының экрандық формасы

Өткізу модулі:

Процедура ОбработкаПроведения()

Регистр.Доходы.Участник = Участник;


Регистр.Доходы.Статья = Статья;
Регистр.Доходы.Сумма = Сумма;
Регистр.Доходы.ДвижениеВыполнить();

Регистр.Кошельки.Кошелек = Кошелек;


Регистр.Кошельки.Сумма = Сумма;
Регистр.Кошельки.ДвижениеПриходВыполнить();

КонецПроцедуры




«Шығыс» құжаты

Құжаттың экрандық формасы келесідегідей болады:



Сурет 55 –«Кіріс» құжатының экрандық формасы
Өткізу модулі:

Процедура ОбработкаПроведения()

Регистр.Расходы.Участник = Участник;
Регистр.Расходы.Статья = Статья;
Регистр.Расходы.Сумма = -Сумма;
Регистр.Расходы.ДвижениеВыполнить();

Регистр.Кошельки.Кошелек = Кошелек;


Регистр.Кошельки.Сумма = Сумма;
Регистр.Кошельки.ДвижениеРасходВыполнить();

КонецПроцедуры



«Аудару» құжаты

Берілген құжат бір кошелектің қаржатын екіншісіне тасымалдайды.



Сурет 56 –«Аудару» құжатының экрандық формасы
Өткізу модулі:

Процедура ОбработкаПроведения()

Регистр.Кошельки.Кошелек = КошелекОткуда;
Регистр.Кошельки.Сумма = Сумма;
Регистр.Кошельки.ДвижениеРасходВыполнить();

Регистр.Кошельки.Кошелек = КошелекКуда;


Регистр.Кошельки.Сумма = Сумма;
Регистр.Кошельки.ДвижениеПриходВыполнить();

КонецПроцедуры



«Қалдық» есебі

Есептің диалогінің экрандық формасы келесідей болып көрінеді:



Сурет 57 –«Қалдық» есбінің экрандық формасы

Есеп модулі:

Процедура Сформировать()

Запрос = СоздатьОбъект("Запрос");

ТекстЗапроса = "
|Кошелек = Регистр.Кошельки.Кошелек;
|Участник = Регистр.Кошельки.Кошелек.Участник;
|Сумма = Регистр.Кошельки.Сумма;
|Группировка Кошелек;
|Функция СуммаВКошельке = КонОст(Сумма);
|Условие(Кошелек в ВыбрКошелек);
|Условие(Участник в ВыбрУчастник);
|";

Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда


.......Возврат;
КонецЕсли;

Таб = СоздатьОбъект("Таблица");

Таб.ВывестиСекцию("Все<");

Пока Запрос.Группировка(1) = 1 Цикл


....... Таб.ВывестиСекцию("Кошелек");
КонецЦикла;

Таб.ВывестиСекцию("Все>");


Таб.Показать();

КонецПроцедуры


Есептің жұмыс жасау мысалы келесі формада көрсетілген.

Сурет 58 –«Қалдық» есебінің соңғы экрандық формасы
«Кіріс және шығыс» есебі

Есептің диалогінің экрандық формасы келесідегідей болып көрінеді:



Сурет 59 –«Кіріс және шығыс» есебінің экрандық формасы
Алдымен есептің типі көрсетіледі: кіріс немесе шығыс. Содан кейін есеп құрастырылатын уақыт аралығы көрсетіледі. Есепте 1 немесе 2 группировканы: «Участники» немесе «Статьи» кез-келген тәртіпте көрсете беруге болады. Сонымен қатар бір ғана қатысушы немесе статья бойынша таңдау алуға болады. Есептің модулін «Денежки» конфигурациясында қараңыз.
Каталог: ebook -> umkd
umkd -> «Dream Wiver және Front Page негізінде желілік ресурстар жасау»
umkd -> «Ақпараттық технологиялар» пәнінен оқу-әдістемелік кешені
umkd -> 5В050400 «Журналистика» мамандығына арналған
umkd -> «шетел тарихнамасының жаңа бағыттары»
umkd -> Тарих кафедрасы
umkd -> ПӘннің ОҚУ-Әдістемелік кешені «Жоғары оқу орындарында тарихты оқыту әдістемесі»
umkd -> Жұмыс бағдарламасы Дәрістер конспектісі Практикалық және семинарлық сабақтар Зертханалық практикум
umkd -> Қазақстан Республикасының білім және ғылым министрлігі
umkd -> Қазақстан Республикасының білім және ғылым министрлігі
umkd -> Сабақ түрлері бойынша пәннің мазмұны және сағаттарын бөлу


Достарыңызбен бөлісу:
1   2   3   4   5


©dereksiz.org 2019
әкімшілігінің қараңыз

    Басты бет