Анықтамалық есеп берулер кезіндегі мәліметтерді енгізу үшін немесе құжаттарды толтыру үшін қолданылатын бір типті объектілер. Көбінесе анықтамалықтар болып қызметкерлер, мекемелер, материалдар тізімі болып табылады



бет5/5
Дата26.06.2016
өлшемі1.28 Mb.
түріАнықтамалық
1   2   3   4   5

Бақылау сұрақтары:

1) Бұл жұмыста қандай анықтамалықтар қолданылады?

2) Жұмыстың мақсаты қалай?

3) «Кіріс және шығыс» есебі дегенімізді қалай түсінесің?

4) «Кіріс және шығыс» есебінің экрандық формасын

түсіндіріңіз?



Практикалық жұмыс №6. Кітапханадағы кітаптарды

есепке алу жүйесі
Мақсаты: Кітапхана үшін оқырмандарға кітаптарды беруге мүмкіндік беретін, оқырманның қарыздарын қадағалап отыратын және берілген уақыт аралығындағы орындалған есептерді құруға мүмкіндік беретін есеп жүйесін құру болып табылады.

Көрініп тұрғандай, конфигурацияда «Книги» анықтамалығы болуы тиіс. Әр кітаптың ерекше кітапханалық нөмірі (код) бар. Айта кететін жайт, бір туындының бірнеше көшірмесі болуы мүмкін.

Көрініп тұрғандай, конфигурацияда «Читатели» анықтамалығы болуы қажет. Әр оқырманға ерекше нөмірі бар оқырман билеті беріледі.

Бағдарламада келесі оқиғалар тіркелуі керек:



  • Кітапханадан кітап оқырманға белгілі бір мерзімге берілуі тиіс;

  • Кітап берілу мерзімі ұзартылуы тиіс;

  • Оқырманның кітапты кітапханаға қайтаруы;

  • Оқырманның кітапты жоғалтып алуы.

Конфигурацияда әр оқиға үшін сәйкесінше құжат қарастырылуы қажет.

Кітапхана жұмысының ережелері келесі:



  • Оқырман кітапханадан тек белгілі-бір мөлшердегі кітаптарды ғана ала алады (кітап мөлшері кітапхана директорымен бекітіледі);

  • Оқырман әдетте кітапты бір айға ғана алады, бірақ егер ол алдын-ала айтатын болса, одан ұзақ мерзімге алуына болады;

  • Оқырман кітапты тапсыру мерзімін ұзарта алады, яғни ол кітапты бекітілген мерзімнен кейінірек әкелетінін хабарласа;

  • Кітапты әкелу мерзімі өтіп кетсе, оқырман ескерту алады;

  • Егер оқырманның ескертулері шамадан тыс асып кетсе, ол 1 ай кітапханамен қолдана алмайды;

  • Кітапты жоғалтып алған жағдайда, оқырман,а ескертулер санына қарамастан, 1 ай кітапханаға келуіне тиым салынады;

Бағдарламада белгілі-бір уақыт мерзімінде орындалған іс-әрекетті көрсететін кітапханалық есеп беру мүмкіншілігі болуы тиіс. Есеп беруді көрсетілген оқырман және/немесе көрсетілген кітап бойынша өткізуге мүмкіншілктері болуы тиіс.

Бағдарламада белгілі-бір оқырманның дәл сол уақыттағы нақты қарыздарын білуге, яғни оның қолында қандай кітаптар бар және ол оларды қашан қайтару керектігі жайында ақпарат алуына мүмкіншілігі болуы қажет.


Конфигурация объектілері

Конфигурацияда келесі объектілерді құру қажет:



Объекттер типі

Объекттер

Тұрақтылар

  • МаксКолвоПредупреждений

  • МаксКолвоКнигНаРуках

  • КолвоДнейБлокировки

  • КолвоДнейДляВыдачи

Анықтамалықтар

  • Произведения

  • Книги (подчинен спр. Произведения)

  • Оқырмандар

  • ЖанрыКниг

  • Авторлары

Тізбектеу

  • СтатусКниги (мәні: Свободна, Выдана, Списана)

  • ДаНет (значения: Да, Нет)

Құжаттар

  • ВыдачаКниги

  • ПродлениеКниги

  • ВозвратКниги

  • ПотеряКниги

Құжаттар журналы

  • Кітапхана

Есеп берулер

  • БиблиотечнаяВыписка

  • ДолгиЧитателя


«Произведения» анықтамалығы

«Произведения» анықтамалығының экрандық формасы келесі түрде болуы қажет:




Сурет 60 –«Произведения» анықтамалығының экрандық формасы

«Книги» (форма списка) анықтамалығы

«Книги» анықтамалығының экрандық формасы келесі түрде болуы қажет:



Сурет 61 –«Произведения» анықтамалығының кестелік формасы

«Выдача книги» құжаты

Құжаттың экрандық формасы келесідегідей болады:



Сурет 62 –«Выдача книги» анықтамалығының кестелік формасы
Форманың модулін «Мини-библиотека» конфигурациясынан қараңыз.
Өткізу модулі:

Процедура ОбработкаПроведения()

СпрКниги = создатьОбъект("Справочник.Книги");
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл

СпрКниги.НайтиЭлемент(Книга);


СпрКниги.Статус = Перечисление.СтатусКниги.Выдана;
СпрКниги.Читатель = Читатель;
СпрКниги.ДатаВыдачи = ДатаДок;
СпрКниги.СрокВозврата = СрокВозврата;
СпрКниги.Записать();

КонецЦикла;

КонецПроцедуры
«Продление книги» құжаты

Құжаттың экрандық формасы келесідегідей болады:



Сурет 63 –«Продление книги» құжатының кестелік формасы
Форманың модулін «Мини-библиотека» конфигурациясынан қараңыз.
Өткізу модулі:

Процедура ОбработкаПроведения()

СпрКниги = создатьОбъект("Справочник.Книги");
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл

Если Число(НовыйСрокВозврата)<>0 Тогда

СпрКниги.НайтиЭлемент(Книга);
СпрКниги.СрокВозврата = НовыйСрокВозврата;
СпрКниги.Записать();

КонецЕсли;

КонецЦикла;

КонецПроцедуры


«Возврат книги» құжаты

Құжаттың экрандық формасы келесідегідей болады:



Сурет 64 –«Возврат книги» құжатының кестелік формасы
Форманың модулін «Мини-библиотека» конфигурациясынан қараңыз.
Өткізу формасы:

Процедура ОбработкаПроведения()

СпрКниги = создатьОбъект("Справочник.Книги");
СпрЧитатели = СоздатьОбъект("Справочник.Читатели");

ВыбратьСтроки();


Пока ПолучитьСтроку()=1 Цикл

СпрКниги.НайтиЭлемент(Книга);

Если СпрКниги.СрокВозврата < ДатаДок Тогда

СпрЧитатели.НайтиЭлемент(Читатель);


СпрЧитатели.КоличествоПредупреждений = СпрЧитатели.КоличествоПредупреждений + 1;
СпрЧитатели.Записать();

Если СпрЧитатели.КоличествоПредупреждений > Константа.МаксКолвоПредупреждений Тогда

УстановитьРеквизитСправочника(Читатель, "Блокирован",Перечисление.ДаНет.Да, ДатаДок);
УстановитьРеквизитСправочника(Читатель, "Блокирован",Перечисление.ДаНет.Нет, ДатаДок + Константа.КолвоДнейБлокировки);

КонецЕсли;

КонецЕсли;

СпрКниги.Статус = Перечисление.СтатусКниги.Свободна;


СпрКниги.Читатель = 0;
СпрКниги.ДатаВыдачи = 0;
СпрКниги.СрокВозврата = 0;
СпрКниги.Записать();

КонецЦикла;

КонецПроцедуры
«Потеря книги» құжаты

Құжаттың экрандық формасы келесідегідей болады:



Сурет 65 –«Потеря книги» құжатының экрандық формасы
Форманың модулін «Мини-библиотека» конфигурациясынан қараңыз.
Өткізу модулі:

Процедура ОбработкаПроведения()

СпрКниги = создатьОбъект("Справочник.Книги");

ВыбратьСтроки();


Пока ПолучитьСтроку()=1 Цикл

СпрКниги.НайтиЭлемент(Книга);


СпрКниги.Статус = Перечисление.СтатусКниги.Списана;
СпрКниги.Читатель = 0;
СпрКниги.ДатаВыдачи = 0;
СпрКниги.СрокВозврата = 0;
СпрКниги.Записать();

КонецЦикла;

УстановитьРеквизитСправочника(Читатель, "Блокирован", Перечисление.ДаНет.Да, ДатаДок);
УстановитьРеквизитСправочника(Читатель, "Блокирован", Перечисление.ДаНет.Нет, ДатаДок + Константа.КолвоДнейБлокировки);

КонецПроцедуры


«Библиотечная выписка» есебі

Есеп диалогінің экрандық формасы келесідей болады:



Сурет 66 –«Библиотечная выписка» құжатының экрандық формасы

Есептің жұмыс жасау мысалы:



Сурет 67 –«Библиотечная выписка» құжатының соңғы экрандық формасы
Форманың модулін «Мини-библиотека» конфигурациясынан қараңыз.
«Долги читателя» есебі

Есеп диалогінің экрандық формасы келесідей болады:



Сурет 68 –«Долги читателя» есебінің формасы

Есеп жұмысының мысалы:



Сурет 69 –«Долги читателя» есебінің соңғы экрандық формасы

Форманың модулін «Мини-библиотека» конфигурациясынан қараңыз.


Өткізу формасы:

Процедура ОбработкаПроведения()

СпрКниги = создатьОбъект("Справочник.Книги");
СпрЧитатели = СоздатьОбъект("Справочник.Читатели");

ВыбратьСтроки();


Пока ПолучитьСтроку()=1 Цикл

СпрКниги.НайтиЭлемент(Книга);




Тапсырмалар

Сіздерге өз беттеріңізше келесі қосымша функцияларды іске асыруларыңыз ұсынылады:



  • Керек кітапты аты, авторы, жанры және басқа да белгілі белгілері бойынша іздеуді;

  • Штрих-кодтау технологиясы. Әр оқырманға және әр кітапқа ерекше штирх код беріледі. Экрандық формаларда оқырманды таңдау штрих-кодты оқу жолымен жүргізіледі, бағдарлама оқырманды немесе кітапты штрих-коды арқылы іздеп табуы қажет.

  • Ақшалай есеп. Әр кітаптың белгілі құндылығы бар және кітапхана коммерциялық деп есептейік. Күн сайын оқырман алған кітап директор орнатқан бағамен сәйкетелген бағамен төленуі керек. Кітапты жоғалтқан жағдайда оқырман штраф төлеуі қажет.

  • Құжаттарды қабылдамау. Құжаттарды өткізуді терістеу кезінде, ол жүйеде жасаған барлы өзгертулер де терістетілуі қажет.

  • Мүмкін сіз тіркеуді тек анықтамалық пен құжаттарда ғана емес, регистрде де іске асырғыңыз келетін шығар;

  • Кәдімгі кітапхананың жұмысы үшін қажет деп ойлайтын басқа да қосымща функцияларды да қосуыңызға болады.



Бақылау сұрақтары:

1) Бұл жұмыста қандай анықтамалықтар қолданылады?

2) Құжат дегеніміз не?

3) Регистр дегеніміз не?



Практикалық жұмыс №7. Дүкен жүйесі
Мақсаты: Үйге алып келетін дүкен үшін оңай тіркеу жүйесін құру керек.

Жүйе тауар қалдықтарын есептеуі қажет, клиент тапсырысын қабылдап және тасушылар үшін жол парақтарын құрастыру.


Конфигурация объектілері

Конфигурацияда келесі объектілерді құру қажет:



Объекттер типі

Объекттер

Анықтамалықтар

  • Клиенты

  • Товары

  • Курьеры

  • Районы



Құжаттар

  • ПриходТовара

  • Заказ

  • СнятиеЗаказа

  • ПутевойЛист

  • ОтчетКурьера

Регистрлер

Регистр

Измерения

Ресурсы

Остатки (регистр остатков)

Товар

Количество

Заказы (регистр остатков)

Товар
Клиент
Заказ
Цена
ДатаДоставки

Количество
Сумма

Доставка (регистр остатков)
(хранит доставляемые в данный момент товары)

Товар
Клиент
Заказ
Цена
ДатаДоставки

Количество
Сумма

Доходы (оборотный регистр)

Товар
Клиент

Доход




Есеп берулер

  • Товары

  • Сводная таблица

Анықтамалықтар

Дүкеннің тапсырыс қабылдайтын аумағы райондарға бөлінеді. Клиентті тіркеу кезінде оның аты көрсетіледі / ФИО, адрес, телефон және район. «Курьеры» анықтамалығында тасушылардың аты-жөндері тізбектелген немесе сатып алушыларға тауарларын тасудағы мобильдік отрядтардың аттары тізбектелген. «Товары» анықтамалығы иерархиялық болып табылады және 3 деңгейден тұрады, яғни тауарлар топқа біріктірілуі мүмкін. Тауардың клиенттерге сатылатын бағалары көрсетіледі.


Тауар кірісі

Құжаттың экрандық формасы келесідегідей болып көрінеді:



Сурет 70 –«Тауар кірісі» құжатының экрандық формасы
Құжатты өткізу барысында «Остатки» регистрінде қозғалыс жүргізіледі:
Процедура ОбработкаПроведения()

ВыбратьСтроки();


Пока ПолучитьСтроку()=1 Цикл

Регистр.Остатки.Товар = Товар;


Регистр.Остатки.Количество = Количество;
Регистр.Остатки.ДвижениеПриходВыполнить();

КонецЦикла;

КонецПроцедуры
Тапсырыс құжаты

Құжаттың экрандық формасы келесідегідей болып көрінеді:



Сурет 71 –«Тапсырыс» құжатының экрандық формасы

Құжатты өткізу барысында «Заказы» регистрінде қозғалыс жүргізіледі:


Процедура ОбработкаПроведения()

ВыбратьСтроки();


Пока ПолучитьСтроку()=1 Цикл

Регистр.Заказы.Товар = Товар;


Регистр.Заказы.Клиент = Клиент;
Регистр.Заказы.ДатаДоставки = ДатаДоставки;
Регистр.Заказы.Заказ = ТекущийДокумент();
Регистр.Заказы.Цена = Цена;
Регистр.Заказы.Количество = Количество;
Регистр.Заказы.Сумма = Сумма;
Регистр.Заказы.ДвижениеПриходВыполнить();

КонецЦикла;

КонецПроцедуры
Тапсырысты алып тастау құжаты

Құжат алдында жасалған тапсырысты алып тастау үшін жасалынған. Алдында тапсырыс жасалған тауар мөлшерін азайтуға болады. Құжаттың экрандық формасы келесідей болады:



Сурет 72 –«Тапсырысты алып тастау» құжатының экрандық формасы
Қолданушы клиентті көрсетеді, бірақ мұндайда берілген клиент бойынша алдындағы тапсырыстар құжаттың кестелік бөлімінде автоматты түрде толтырыла береді. Қолданушы қажет тауар мөлшерін «Снять» бағанасында көрсете береді.
Құжатты өткізу барысында «Заказы» регистрінде қозғалыс жүргізіледі:

Процедура ОбработкаПроведения()

ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл

Если Количество > 0 Тогда

Регистр.Заказы.Товар = Товар;
Регистр.Заказы.Клиент = Клиент;
Регистр.Заказы.ДатаДоставки = ДатаДоставки;
Регистр.Заказы.Заказ = Заказ;
Регистр.Заказы.Цена = Цена;
Регистр.Заказы.Количество = Количество;
Регистр.Заказы.Сумма = Сумма;
Регистр.Заказы.ДвижениеРасходВыполнить();

КонецЕсли;

КонецЦикла;

КонецПроцедуры



Жол парағы құжаты

Берілген құжат сатып алушыға тауарды жеткізіп салатын тасушыға тапсырма болып табылады. Құжаттың экрандық формасы келесідегідей болады:



Сурет 73 –«Жол парағы» құжатының экрандық формасы
Алдымен қолданушы районды көрсетеді, мұндайда кестелік бөлігі автоматты түрде толтырылады – жол парағы дайындалады. Бағдарлама берілген район бойынша жасалған барлық тапсырыс мерзімі сәйкес келетін немесе ол мерзімнен кешігіп қалып қойған тапсырыстарды қарастырады. Қолданушы жеткізілетін мөлшерді «Доставить» бағанасында тауардың складта жоқтығымен немесе тауардың бір тасымалдаушыға ауыр екендігімен байланысты дұрыстай алады.

Осыдан кейін жол парағы басып шығарылады да өткізіледі. Басып шығарылған жол парағы келесідей болады:




Сурет 74 –«Жол парағы» құжатының соңғы экрандық формасы

Құжатты өткізу барысында «Остатки и Доставка» регистрінде қозғалыс жүргізіледі:


Процедура ОбработкаПроведения()

ВыбратьСтроки();


Пока ПолучитьСтроку()=1 Цикл

//доставляемые товары


Регистр.Доставка.Товар = Товар;
Регистр.Доставка.Клиент = Клиент;
Регистр.Доставка.Заказ = Заказ;
Регистр.Доставка.Цена = Цена;
Регистр.Доставка.ДатаДоставки = ДатаДоставки;
Регистр.Доставка.Количество = Количество;
Регистр.Доставка.Сумма = Сумма;
Регистр.Доставка.ДвижениеПриходВыполнить();

//уменьшаются остатки по данному товару


Регистр.Остатки.Товар = Товар;
Регистр.Остатки.Количество = Количество;
Регистр.Остатки.ДвижениеРасходВыполнить();

КонецЦикла;

КонецПроцедуры

Тасушы есебі

Берілген құжат тасушының жол парағы бойынша жүрген жол нәтижесін көрсетеді. Жеткізілген тауарлар мөлшері белгіленеді. Құжаттың экрандық формасы келесідей болады:



Сурет 75 –«Тасушы» құжатының экрандық формасы
Қолданушы тасушы есеп беретін жол парағын көрсетеді. Мұндайда құжаттың кестелік бөлігі автоматты түрде толтырылады. Қолданушы «Доставлено» бағанасын жеткізіліп салынған тауарлар мөлшерімен толытырып дұрыстай алады. «Недоставленные товары возвращены на склад» деген жерде жалауша қойылса, онда тауарлар «Доставка» регистрінен «Остатки» регистріне ауысады, яғни тасушы бізге ештеңе қарыз емес.

Құжатты өткізу барысында регистрлерде қосғалыстар жүргізіледі:


Процедура ОбработкаПроведения()

ВыбратьСтроки();


Пока ПолучитьСтроку()=1 Цикл

Если Доставлено > 0 Тогда

Регистр.Доставка.Товар = Товар;
Регистр.Доставка.Клиент = Клиент;
Регистр.Доставка.Цена = Цена;
Регистр.Доставка.Заказ = Заказ;
Регистр.Доставка.ДатаДоставки = ДатаДоставки;
Регистр.Доставка.Количество = Доставлено;
Регистр.Доставка.Сумма = Сумма;
Регистр.Доставка.ДвижениеРасходВыполнить();

Регистр.Заказы.Товар = Товар;


Регистр.Заказы.Клиент = Клиент;
Регистр.Заказы.ДатаДоставки = ДатаДоставки;
Регистр.Заказы.Цена = Цена;
Регистр.Заказы.Заказ = Заказ;
Регистр.Заказы.Количество = Доставлено;
Регистр.Заказы.Сумма = Сумма;
Регистр.Заказы.ДвижениеРасходВыполнить();

Регистр.Доходы.Товар = Товар;


Регистр.Доходы.Клиент = Клиент;
Регистр.Доходы.Доход = Сумма;
Регистр.Доходы.ДвижениеВыполнить();

КонецЕсли;

Если Фл_ВозвратОстатков=1 Тогда

Если Доставлено < Заказано Тогда

Регистр.Доставка.Товар = Товар;
Регистр.Доставка.Клиент = Клиент;
Регистр.Доставка.Цена = Цена;
Регистр.Доставка.Заказ = Заказ;
Регистр.Доставка.ДатаДоставки = ДатаДоставки;
Регистр.Доставка.Количество = Доставлено;
Регистр.Доставка.Сумма = Сумма;
Регистр.Доставка.ДвижениеРасходВыполнить();

Регистр.Остатки.Товар = Товар;


Регистр.Остатки.Количество = Заказано - Доставлено;
Регистр.Остатки.ДвижениеПриходВыполнить();

КонецЕсли;

КонецЕсли;

КонецЦикла;

КонецПроцедуры

«Тауарлар» есебі

Берілген есеп сол уақыттағы тауарлар бойынша суретті көрсетеді және көрсетілген болашақтағы уақыт мерзіміне жетіспейтін тауарларды бағалайды. Есеп диалогінің экрандық формасы келесідей болады:



Сурет 76 –«Тауарлар» құжатының экрандық формасы
Қолданушы белгілі-бір тауарлар тобын таңдауды шектеуі мүмкін. Сонымен қатар, қолданушы тапсырыстар есепке алынатын уақыт аралығын күнмен көрсете алады. Бұл жеткіліксіз тауарларды алдын-ала біліп отыруға және тапсырысты жеткізудің тоқтатылып қалмауын қадағалайды. Есеп жұмысының мысалы төменде келтірілген:

Сурет 77 –«Тауарлар» құжатының соңғы экрандық формасы

Жетіспеушілік келесі формуламен анықталады:

Дефицит = (Заказано - Доставляется) - Остаток;
Бақылау сұрақтары:

1) Бұл жұмыста қандай анықтамалықтар қолданылады?

2) Жұмыста қандай регистрлер қолданылды?

3) Экрандық форма дегенімізді қалай түсінесің?





Каталог: ebook -> umkd
umkd -> «Dream Wiver және Front Page негізінде желілік ресурстар жасау»
umkd -> «Ақпараттық технологиялар» пәнінен оқу-әдістемелік кешені
umkd -> 5В050400 «Журналистика» мамандығына арналған
umkd -> «шетел тарихнамасының жаңа бағыттары»
umkd -> Тарих кафедрасы
umkd -> ПӘннің ОҚУ-Әдістемелік кешені «Жоғары оқу орындарында тарихты оқыту әдістемесі»
umkd -> Жұмыс бағдарламасы Дәрістер конспектісі Практикалық және семинарлық сабақтар Зертханалық практикум
umkd -> Қазақстан Республикасының білім және ғылым министрлігі
umkd -> Қазақстан Республикасының білім және ғылым министрлігі
umkd -> Сабақ түрлері бойынша пәннің мазмұны және сағаттарын бөлу


Достарыңызбен бөлісу:
1   2   3   4   5


©dereksiz.org 2019
әкімшілігінің қараңыз

    Басты бет